TopSolid 7.17
What's New
Contents

Welcome to TopSolid 2023 ........................................................................................................... 1

What's New in TopSolid‘Design 7.17 ............................................................................................ 3
  User Interface and Ergonomics ...................................................................................................... 4
  PDM ................................................................................................................................................ 7
  Sketch ............................................................................................................................................ 10
  Shape ............................................................................................................................................ 14
  Surface ......................................................................................................................................... 15
  Sheet Metal .................................................................................................................................... 16
  Assembly ....................................................................................................................................... 17
  Building ....................................................................................................................................... 21
  Family, Wizard and Process ........................................................................................................... 23
  BOM ............................................................................................................................................... 24
  Visualization ................................................................................................................................. 25
  Analysis ....................................................................................................................................... 25
  Construction ................................................................................................................................. 25
  Tools ............................................................................................................................................. 28
  Materials and Textures ................................................................................................................ 32
  Nesting (Optional Module) .......................................................................................................... 33
  Bar Nesting .................................................................................................................................. 37
  TopSolid‘Fea .................................................................................................................................. 38
  Drafting ........................................................................................................................................ 39
  Unfolding .................................................................................................................................... 50
  Interfaces ...................................................................................................................................... 51
  Viewer .......................................................................................................................................... 53
  PDM Explorer (Optional Module) ............................................................................................... 53

What's New in TopSolid‘Cam 7.17 ............................................................................................... 55
  Drilling ......................................................................................................................................... 56
  2D Milling .................................................................................................................................... 58
  3D Milling .................................................................................................................................... 64
  5D Milling .................................................................................................................................... 70
  Turning ........................................................................................................................................ 73
  Inter-operations ............................................................................................................................ 76
  Tools and Cutting Conditions ....................................................................................................... 79
  Verification and Simulation .......................................................................................................... 83
  Methods ....................................................................................................................................... 86
  Miscellaneous ................................................................................................................................. 88
  Grinding ....................................................................................................................................... 94
What's New in TopSolid'Cut 7.17 ................................................................. 115
  Skeleton Cutting ............................................................................. 116
  Waste Cutting .............................................................................. 120
  Delivery of Standard Leads by Default ......................................... 126
  Common Cutting ........................................................................... 128
  Automatic Link Bypass .................................................................. 132
  Scrap Cutting ............................................................................... 134
  Show/Hide the Start and End Points ............................................ 137
  Additional Positionings for a Unit Part ......................................... 138
  Clamp Management ...................................................................... 138
  Shifting Area Management for Clamp Machines .......................... 139
  Evacuation of Parts through a Chute Door .................................... 141
  Retrieval of a Machined Format as a Support ............................... 142
  Work Manager ............................................................................. 143
  Work Document ............................................................................ 145

What's New in TopSolid'PartCosting 7.17 ............................................. 147
  Turning on a 3D Drawing ................................................................. 148
  Profile Without Drawing ................................................................. 148
  Hourly Rates Management ............................................................ 149
  TopSolid'Cam Cutting Conditions ................................................ 149
  Mill/Turn Spindle Speed Limit ....................................................... 150
  Sweeping Operation ...................................................................... 150

What's New in TopSolid'Inspection 7.17 ................................................. 151
  TopSolid'Inspection Creator ............................................................ 152
  TopSolid'Inspection Controller ...................................................... 157
Welcome to TopSolid 2023

Throughout this document, you will discover the main enhancements and learn about the new features and benefits of the latest 7.17 release of TopSolid 7. The innovations described here only represent a small portion of the new features.

If you are interested in finding out more about the newest TopSolid 2023 features, please visit our eLearning page, or contact your local reseller.
What's New in TopSolid'Design 7.17
This section describes the enhancements made to the PDM, Design, Sheet Metal, Nesting, FEA, Drafting, Unfolding and Bar Nesting applications in version 7.17 of TopSolid 7.

**User Interface and Ergonomics**

**Launching commands**

The F3 key or the command search icon located at the top right of the screen allows you to display a quick search bar in which you can enter the first few characters of the command and a list of commands containing these characters will appear, just like in Windows.

![Quick search bar example](image)

**Shape icons**

In the Entities tree, surface, solid and faceted shapes are now differentiated by specific icons.

![Shape icons example](image)
Drop-down lists with previews

When selecting a material or coating or when including a profile or a family, the name of the document as well as the name of the project or the library are now displayed in the document preview.

Parts tree

The Parts tree now allows you to show, sort and/or filter BOMs according to criteria and to edit the characteristics of one or more parts.
The list of editable characteristics can be configured in the Characteristics section of the Tools > Options command.
**3DConnection mouse**

The 3DConnection mouse interface has been improved. In addition to managing the sensor with 6 degrees of freedom, it is now possible to configure the buttons of that device for each document type (part, assembly, machining, etc.).

---

**Library design**

LibraryDesigner module commands are now available by adding the argument "-a" in the TopSolid launch shortcut; a LibraryDesigner license is no longer required.

**Online help**

The online help displayed by default is the online help available over the Internet.
PDM

Copying and pasting projects

You can now copy and paste one or more projects from the project manager window.

Validation

You can now use the validation command to validate multiple documents at once. The command can also be launched when a file is selected, and it can also be launched recursively. TopSolid has also added an option which allows you to make prior revisions obsolete.

TopSolid has also added a Recursive option to the Check Out for Edit and Check in commands.
Performance enhancements

The display of project content has been improved and is now 3 to 4 times faster than in version 7.16. Given a library which contains 6,152 documents at the top level, the time required for opening a project has greatly improved, from 16 seconds in version 7.16 to 4 seconds in version 7.17.

In addition, TopSolid has improved times for backups, extraction and restoration (.TopBck file):
- Backup: -25%
- Restoration: -40%
- Extraction: -30%

Given a server that comes with an SSD disk and 128 GB of RAM, the time required for restoring a 140 GB backup has improved from 1 hour 46 minutes in version 7.16 to just 50 minutes in version 7.17.

Restoration

The extraction contextual command now allows you to select which elements to extract, which means you can extract only the SQL database, only the files or only some files by indicating their identifiers.

Example of SQL database extraction.
Check-in on closure

In the PDM section of the Tools > Options command, the Ask for check-in on project closure option has been divided into two options, one for projects and one for libraries.

Multisite

Communication between secondary servers and primary server is now asynchronous. This means that when you check in a large document, you can continue to work without having to wait for the check-in to end.

Publication to ERP

When publishing to TopSolid’Erp, it is now possible to generate the PDF of a draft automatically (via the Tools > Options > Erp section) or manually (via the Import/Export contextual menu).
Sketch

Contextual menus

In order to reduce mouse movements, TopSolid has added a Constraint command to many contextual menus. For example, the command is now available not only when a user selects a point, line or arc, but also when selecting two points, two lines and two arcs, or even when selecting a point and a line, a point and an arc, etc.

In addition, the Dimension command allows you to create constraints for all selected elements.

Group merging

Vertices are no longer merged when a coincidence constraint is created between two groups, which makes it possible to find two separate groups when the constraint is removed.

Spline

TopSolid has added new creation modes (G1 Free, G2 Free, Balanced Tangents (C1) and Balanced curvatures (C2)) to the Spline command, by splitting the Free and Balanced Tangents modes.

Coordinate system

A Name axes according to frame option has been added to the Advanced Options section of the positioning command. As a result, when a user creates a sketch in the XZ plane of a frame, the name of the X and Z axes can be displayed in all creation commands.
Positioning

The new Planar Sketch Positioning section in an assembly document Options tree allows you to define the default positioning mode of planar sketches, either with respect to the absolute frame, with respect to the absolute frame of the part document, or with respect to the frame of the machinable component (assuming the Machinable Component function has been provided in the Part document).

Smoothing

TopSolid has added an Exact option to the By Tolerance mode, allowing you to avoid ripples on fittings.
**Elevated circular spline**

The new 3D Sketch > Other Curves > Elevated Circular Spline command in a 3D sketch allows you to draw a curve passing through points with or without straight sections at the ends. The command comes in useful especially for drawing the curve of a staircase stringer.

The command is also available in sketch operations.

**Optimization**

**TopSolid** has provided a new Others > Accelerated Display contextual mode for imported sketches and sketches in a Drawing document. When accelerated mode is activated, the screen display is faster; in turn however, screen size symbols, such as those which make it possible to view profile ends, are no longer displayed.

**Engraving**

The new 3D Sketch > Operations > Profiles Engraving command allows you to copy and deform sketch profiles, by means of the shades of gray in an image.
TopSolid 2023

What's New in TopSolid’Design 7.17

**Pixelation**

TopSolid has provided two new patterns, Quincunx and On profiles, for the pixelating command.

*Pixelation in quincunx makes it possible to obtain better definition.*

**Interior circles**

The new 2D Sketch > Operations > Profiles Batch > Interior Circles command allows you to automatically create all circles inscribed in a profiles batch.
Shape

Faces modification

The new Slot mode in the Faces Modification command allows you to identify and modify straight and flat slots with or without a bottom radius.

Simplification

In a simplification, the merging option now differentiates between the thread and the associated clearance hole.
Surface

Pipe

The **Pipe** command now has a new **Section in place** option. Unchecking that option allows you to select a section which was created on any plane. This can be useful when the section is used in multiple pipe shapes.

![Pipe command interface](image)

**Face replacement**

Replacement faces in the **Surface > Replacement** command can now be selected on a solid shape.
Sheet Metal

Sheet metal properties

The Sheet Metal Properties command now has a new Rollings Number property.

In addition, previously when sheet metal property calculation was activated in a template document, if the document did not contain sheet metal parts, the properties calculated were set at 0mm for lengths and 0 for numbers. From now on, these properties will be displayed as <not specified> if the document does not contain any sheet metal parts.

Breaking

The new Breaking command now allows you to geometrically create bending lines on a face and in turn to obtain the actual shape of the broken face edges of the sheet metal.

These bend lines can then be unbended like conventional lines in unfoldings. Nevertheless, the geometric processing carried out is complex and may need tolerance adjustments in unfolding and breaking operations.

Sheet metals recognition

The Sheet Metals Recognition command previously had the ability to identify parts and convert them into tubes or profiles. This feature has been improved, and now allows you to recognize:

- Round and square solid tubes with standardized dimensions;
- Round and square tubes with standardized dimensions instead of all possible dimensions;
- T profiles and angles of equal or unequal lengths.

In addition, profile nesting characteristics are automatically provided when parts are converted to tubes or profiles, which makes it possible to use these profiles in bar nesting.
Assembly

Inclusion in last positioning

The Inclusion in Last Positioning mode has been replaced by a mode with three states. The Inclusion in New Positioning and Inclusion in Last Positioning modes correspond to the two modes available in prior TopSolid versions. The Inclusion in Specific Positioning mode allows you to select the positioning in which you want to include your part, or to create a new positioning.

The mode is now saved between two TopSolid sessions.

Local parts and assemblies

The Type for BOM parameter can now be inherited when creating a local part. TopSolid has provided a new drop-down list for creating a local assembly which allows you to select the type for BOM, including Absent, Simple, Composite and Transparent (as for a conventional assembly).
**Parts operations**

In assembly operations, you can now select multiple repetitions in the list of parts for modification.

**Non-synchronizing operations**

In the Assembly > Parts Operation section of the Tools > Options command, you can now indicate that parts and subassemblies are not synchronized during operations (drilling, trimming, etc.) carried out in the assembly.

Non-synchronized operations are indicated by a “#” symbol in the Operations tree. In the event an assembly is modified, the Rebuild not Synchronized Operations contextual command makes it possible for operations in the part or subassembly to be recalculated.
**In-place assembly and local assembly**

When creating an in-place assembly or local assembly, the occurrences of a repetition are now included in an associative manner. As a result, if the number of instances of the repetition is changed, the occurrences are automatically added or removed in the in-place assembly or local assembly.

**Local part and assembly parameters**

You can now create parameters for a local part or assembly. These parameters can then be used in an expression using the following syntax: `@'name of local part'.name of the parameter`. 
**Extruded bars**

Two new advanced options are now available:

- **Part Creation Method**: Allows you to create a derived part or a local part.
- **Profile decomposition**: Allows you to decompose a curved extruded bar into as many parts as segments. Modes: **Yes**, **No** and **Partial** (tangential non-collinear extruded bars).

The default value for the **Part Creation Method** option can be set in **Tools > Options > Assembly > Extruded Bars**.

![Part Creation Method Options](image)

**Trimming local parts**

The **Keep trimmed side** option is now compatible with local parts. When a local extruded bar is being trimmed, this makes it possible, for example, for properties (length, cutting angles, etc.) to be retrieved in the BOM.

**Replacement with wizard**

When a wizard is being edited with dimensioning, the list of families meeting the wizard criteria is now shown to users. In prior versions, only the family used during inclusion was displayed.

**Non-operable component**

The new **TopSolid 7 > File > Inoperable Document** command now allows you to define an inoperable document. The command creates a parameter called **Inoperable** in the **System Parameters** folder of the Entities tree. As a result, it may not be operated by a process or an assembly operation (drilling, trimming, etc.). Nevertheless, the part may be made operable by deriving it for modification, then modifying the **Inoperable** system parameter.

**Verification of shapes**

**TopSolid** has added a **Healing** sub-menu to the **Modeling** menu, which contains the **Check**, **Clean** and **Simplify** commands. The commands allow you to quickly repair all or some of the parts in an imported assembly.
Building

Staircase layout and staircase treads

The Multi-Flight Staircase command in the Modeling menu has been replaced with two new commands which make it easier to create staircases:

- The Staircase Layout command allows you to determine how treads are distributed and to produce a 2D sketch from that distribution. The command also allows you to produce a 3D sketch of treads and/or local shapes for each tread.
- The Staircase Treads command allows you to automatically include a tread component for each tread in a staircase layout.

Profiles mode

TopSolid has provided a new staircase step creation mode, called Profiles, for the Staircase Layout command. The mode is determined by a theoretical treading line and is then limited by profiles. As a result, you can now create staircases with non-linear borders.

Height to cross

The Staircase Layout command in Table or Profiles mode allows you to determine the height to cross by selecting a vertex in the graphics area of the document.
**Ergonomics**

In order to more easily identify the entities produced by the Staircase Layout command, sketches are now named 2D Staircase Sketch and 3D Staircase Sketch. Local shapes are created in a sub-folder called Shapes (Staircase Layout 1) under the Shapes folder.

In addition, the Show/Hide contextual commands allow you to manage how sketches and local shapes produced by the command from the graphics area are displayed.

**Arrival axis**

Staircases sometimes arrive onto landings which are not strictly perpendicular to the treading. The new Arrival axis option provided in the Treads section of the Staircase Layout command allows you to adapt the final step of the staircase to the landing.

![The landing tread is adapted to the landing and is limited by the arrival axis.](image)

![If the landing tread is absent, the final step is adapted to the landing.](image)

**Tread component**

The new T0 tread type allows you to create tread components adapted to layouts produced by a staircase created in Profiles mode.

In addition, new parameters available in the Tread Family family driving make it possible to identify the first and last tread of the staircase.

**Global constraints**

The new Rule option in the Global constraints section allows you to standardize the constraints to be observed when creating a staircase.

Before taking advantage of this option, you must create a specific Staircase Constraint Rules document. Global constraints, meaning the possible ranges of values for rise, run, treading angle, treading step and number of rises, are defined in this document.

When the Rule option is checked, constraint values are filled in by the rule and cannot be changed. Unchecking the Rule option causes ranges to stay the same as those in the rule which was previously selected; however, they can be modified.
Family, Wizard and Process

Linear inclusion

A component driven in length can now behave like an extruded bar. To do this, you simply have to provide the new Linear Component function in the generic document and to provide the Linear Family family driving in the family document. The main advantage of this is not having to create private instances in the family document.

Conditional driver

The Condition command can now be applied to a driver or driver folder. When a family is included, this makes it possible, for example, to disable a driver if the condition is not met.

Wizard

It is now possible in a wizard document to drive the angle of orientation and frame on frame constraints.
Repetition management

When defining an operator, it is now possible to select a repetition of operations.

BOM

Assembly comparison

The Compare parts geometry option has been renamed Compare shapes geometry. The new comparison algorithm makes it possible to compare the geometry of the shapes contained in the representation. For example, you can separate assemblies which have the same properties but contain different geometries, such as a mirror assembly.

In addition, the new Consider local modifications option makes it possible to take into account (or not) any modifications made only in the assembly.
**Visualization**

**Selection**

The **Faceted Shape Vertex Selection** command has been renamed **Special Vertex Selection**, since it also applies to point clouds.

---

**Analysis**

**Manufacturing feature**

Information on pocket type (open or not) is now displayed during an analysis (**Analysis > Analyze** or **F8** key on keyboard).

---

**Construction**

**Block envelopes**

**TopSolid** has made a number of improvements to block envelopes.

A new section has been added, which allows you to indicate a second Z length to manage sloping blocks. The slope can be defined according to the four vertical faces of the block.
It is now possible when creating a constrained block envelope to select the faces and edges of the entities of the background document (provided it was defined as selectable).

A **Block Envelope Up Direction** command has been added to the **Construction > Block Envelopes** menu, which allows you to set the vertical direction (direction of the arrow) when including a component which contains a block envelope.

You can now select block envelopes which have been published without having to show them. The detection is carried out automatically, when you hover over the published block envelope.

**Patterns**

A **Name** field has been added to the dialog box of creation commands for various patterns.

The **Alternating Numbering** checkbox in defining a linear or circular pattern has been replaced with three icons:

- **Sequential**: Same as unchecked **Alternating Numbering** option in prior versions.
- **Alternating**: Same as checked **Alternating Numbering** option in prior versions.
- **Sequential with stable extremities**: Toggle mode with fixed extremities.
**TopSolid** has added a constrained profile pattern. Like the constrained linear pattern, it makes it possible to distribute elements over a profile using the same options of sampling, distribution, margins, etc.

**Animate parameter**

The Construction > Parameters > Animate Parameter command now has a new option for creating a basic surface.

*Example of surface obtained by animating a parameter (ratio).*
**Tools**

*Characteristics*

The new **Characteristics** section in the **Tools > Options** command allows you to define, for each document type, those properties which will be displayed and which will be able to be edited from the BOMs available in the Parts tree (see **Parts tree** section).

**Coating surface**

The new **Tools > Coating Surface** command allows you to calculate a paint surface and create the **Coating Area** parameter of an assembly or part, both automatically and manually.
Warning messages

TopSolid has provided three new options in the Tools > Options > Assembly > Parts Operation command which make it possible to suppress warning messages during synchronization, derivation and conversion into a local part.
**Define process**

The new **Tools > Define Process** command allows you to associate a **Process** document with the generic of a component. This makes it possible in an assembly document to interchange various components (with different processes) without destroying the processes.

**Physical properties**

**TopSolid** has added **Projected Area** and **Enclosing Projected Area** sections to the **Physical Properties** command. Results are displayed in the **System Parameters** folder of the Entities tree.
Annotations

An **Allow annotations in modeling stage** option has been added to the **Tools > Options > Annotation** section. When this option is checked, annotations are created chronologically during the modeling stage, then grouped in a **Modeling Annotations Management** operation.

The **Split Modeling Annotations Management** contextual command allows you to create as many operations as annotations.

Derivation of detailing elements

It is now possible to derive detailing elements, by editing the new **Derivation of Detailing Elements** operation available in the **Annotation** stage. As a result, the derivation of detailing elements can be carried out automatically when that change is made in the template document of the derivation.
Materials and Textures

Materials

TopSolid has added, in the Advanced tab of a Material document, a Melting temperature parameter to the Thermal group, and Cutting Force and Cutting Force Increment parameters to the new Cut group.

The new filters Add Normal, Scale Normal, Max Normal and Min Normal make it possible to emphasize or reduce the characteristics (depth) of a texture.

Textures

It is now possible when defining a texture to integrate textures coming from Adobe Substance 3D (sbsar extension). This texture format has the advantage of being parametric, and the settings are available directly from the material document.
Nesting (Optional Module)

Nesting characteristics

Degrees of freedom

The new Managed by Coating/Material Isotropic option allows you to automatically determine the degrees of freedom of a part, based on its material.
If the material AND the coating have an isotropic composition, rotations are free.
If the material AND/OR the coating are non-isotropic, possible rotations are 0° and 180°.

Multi-layer support

It is now possible to define a panel composed of a multi-layer material as the nesting support.

Automatic nesting

Reorganization of the dialog box

TopSolid has reorganized the dialog box for the Automatic Nesting command:

- A new Created documents tab now allows you to select the type of document created by the nesting and its associated template. The tab has a new Automatic Mode option which makes it possible to automatically associate the document type created by the nesting, based on the type of the documents for nesting. When that option is checked, the list of possible selections is disabled and the application only allows you to select a compatible template document.
- All nesting strategies which can be activated at different locations of the dialog box include the Strategies tab.
- The Nestings results tab is available at the end of the tab list.

Filler part

When the Filler Part option in the Parts tab is checked, the parts quantity is now automatically initialized with an infinite number. In addition, a part will be included in each hole left in the support after the other parts are nested. You can limit that parts quantity by completing the corresponding field.
**Small parts in center**

The new **Little parts on center** option in the **Strategies** tab makes it possible to dictate the positioning of parts in the center of the support based on their size.

The **Window size** section makes it possible to determine the size of the area in which the small parts are to be positioned. The dimensions of parts which are to be considered small parts are given by a box enclosing part, maximum length and width.

---

**Consider the machine environment**

The new **Consider the machine environment** option in the **Created documents** tab allows you to take the clamp safety area into account in the nesting. In order to do so, the document template must contain a machine which has clamps. The clamp area is likewise identified in manual nesting. Parts may not be moved into that area.
**Manual nesting**

**Add part**

You can now add new parts to an automatic or manual nesting, directly from the *Add part* contextual command called from a row of the parts table.

The manual nesting dialog box will appear automatically and allow you to position the part.

![Manual nesting dialog box](image)

**Dialog box modification**

The *Enclosing box* option has been removed from the manual nesting dialog box. However, it is still available in automatic nesting.

**Consider generated wastes**

In a manual nesting, the new *Consider generated wastes* advanced option makes it possible to take into account any waste cuttings which may be carried out in the sheet metal cam document generated by the nesting. As a result, parts may not be positioned in those zones.

![Consider generated wastes](image)
Check options

Material
You no longer need to enter the material to be tested in a verification of the materials of parts and of the support. The check now makes it possible to verify the consistency of the materials in a parts/support pair.

Security gaps
The security gap verification is no longer available in the nesting dialog box. As a matter of fact, the calculation time involved in that check was too sizable for it to be required at each update.

From now on, it will only be possible to perform the check by request, from the Check Options command in the Advanced Options section. Executing the verification causes any safety zones which conflict with a part to be shown in orange. The results of the analysis are not saved when you exit from the command.

Nesting operator file

Support properties
In prior versions, in cases where nestings used several different supports, the properties of those supports such as reference, material and thickness were not retrieved into operator files.

Now, if those properties are identical between each support, they are displayed.
In cases where they are different between supports, the properties are concatenated, except for material, which will be set to 0mm.

Automatic property index model
The new Automatic Property Index Model command now allows you to show the index numbers of parts stored in the Nested Part List properties table in chapter views.
Bar Nesting

Created Documents

TopSolid has reorganized the dialog box for the Automatic Bar Nesting command. A new Created documents tab now allows you to select the type of document created by the nesting and its associated template. The tab has a new Automatic Mode option which makes it possible to automatically associate the document type created by the nesting, based on the type of the documents for nesting. When that option is checked, the list of possible selections is disabled and the application only allows you to select a compatible template document.

Consideration of cutting angles

In prior TopSolid versions, the Automatic Bar Nesting command took bars to be nested into account only according to their enclosing box. It is now possible to take into account the cutting angles at their two ends.

Two new options are available in the Parts tab:
- The Allow Flip option makes it possible to nest a part by rotating it around the X or Y axis of its reference frame.
- The Degrees of Freedom option makes it possible to allow the rotation of a part around the Z axis of its reference frame.
  These part characteristics are automatically filled in by the extruded bar nesting characteristics provided to the nested parts.

Consideration of support waste

In prior TopSolid versions, the Automatic Bar Nesting command only took a single support reference into account. It is now possible to add multiple supporting profiles by managing their filling priorities. This new feature allows you to process the filling of waste before starting on new bars.

In addition, support wastes are now taken into account in a Work document.

Universal support

You can now use a universal bar nesting support (available in the TopSolid library). This support makes it possible to nest any type of extruded bar, regardless of its section. It is all the more useful in the context of creating a bar nesting via a Work document, since it can be included in the work template. This thus avoids having to enter a support for each type/code of the extruded bar to be nested.
As a result, the properties of the supports in the assemblies produced by a bar nesting are those of the first extruded bar nested for that support.
**Automatic dimensioning in drafting**

The **Automatic Dimensions** command in a drafting document now makes it possible to automatically dimension the views of the bar nestings carried out in **TopSolid**.

When the **Multi Extruded Bars Dimensions Optimization** option in advanced options is checked, the cutting angles and length are dimensioned, and the position of the dimensions is optimized to avoid overlaps.

To take advantage of this improvement in version 7.17, you must upgrade the automatic dimensioning operations in drafting templates.

---

**TopSolid’Fea**

**Modifying beams and shells**

A **Hide** option was added to dialog boxes for editing beams and shells.
Drafting

Mirror drafting

The new Tools > Mirror Drafting command allows you to obtain the symmetrical draft of a drafting document.

Dimensioning

The Delete command is available in the contextual menu of the Detailing > Dimension, Detailing > 3D Dimension, Detailing > Half Part Dimension and Detailing > Arc Length Dimension commands.

Composite dimensioning

The Detailing > Composite Dimension, Detailing > Automatic Composite Dimensions and Detailing > Automatic Bending Composite Dimensions commands now have an option which allows you to select the style of the dimension. The style is only used when new dimensions are created. If the dimension style is deleted, the composite dimensions operation becomes invalid.
In addition, TopSolid has added an **Ignore Extruded Bar Extremities** option to the **Detection** section which makes it possible to suppress dimensioning of the faces located at extruded bar extremities (according to the largest length).
Automatic dimensioning of extruded bars

The Detailing > Automatic Dimensions command has been enhanced by the addition of an advanced option called Multi Extruded Bars Dimensions Optimization which allows you to quickly dimension all extruded bars. The option is useful not only for drafting an assembly, but also for dimensioning bar nestings.

Extremities of composite dimensions

In a chained dimensioning (manual or automatic), when the selected adaptation mode is Change extremities and export, a drop-down list allows you to select the extremity type.
Projected annotations

The Track 3D Positions positioning option has been replaced with a drop-down menu with three options:

- **Free**: Annotations can be moved manually.
- **Optimized**: Annotations are placed around the view, observing the positioning distance and the interval between two dimensions (as in the multi extruded bars dimensions optimization).
- **Track 3D positions**: As in prior versions.

Dimensioning with comments

The contextual menu for a dimension now provides a **Comments** submenu which allows you to associate a piece of text to a dimension or note. The position of that comment can then be changed using the stacking, repositioning and annotation separation contextual commands.

In addition, the **Stack Annotation** command dialog box now has a **Follow orientation** checkbox which allows you to indicate that the stacked entity must have the same orientation as the target entity.
**Difference note**

*TopSolid* has added a field making it possible to define a note’s angle of rotation to the main dialog box of the *Difference Note* command.

**BOM index**

An index style can now be specific to an entity type, thanks to the new *Filters* section. As a result, when creating a BOM index, if the *Initialize Style And BOM Document Automatically* option is checked, index styles are automatically selected based on the indexed entity.
A **Positioning Mode** option has been added to the **Detailing > Automatic BOM Index** command. The option allows you to position indices either at the center of the indexed element, offset in relation to the center of the indexed element (in place), or on the frame of the view.

**Note framing**

**TopSolid** has added oblong, ellipse, diamond, pentagon, hexagon and octagon framing types for notes (with the exception of cone notes and level notes) and table indices.
**Drilling table**

It is now possible to create a drilling table (with or without table) not only for an interrupted view, but also for a view which projects an assembly.

In the **Advanced Options** section of the **Drilling** (part and assembly) and **Drilling Group** commands, it is now possible to indicate an additional text item in three different ways:

- **Blank**: No text.
- **Text**: Text entered manually.
- **Property**: A property is retrieved from the component which implemented the drilling.
That information can be retrieved into the **Additional Text** column of a drilling table or into a drilling note.

In addition, the new **Reinitialize Symbol Position** contextual command makes it possible to reposition a symbol to its original location.
**Dimensions table**

Dimensions tables now support all annotation types. In addition, in the case of symbols which have multiple pieces of information, such as roughness symbols, you can now select each element separately.

It is now possible when defining a dimensions table style to add maximum and minimum values for toleranced dimensions.
**Scenario table**

A **Scenario Table** command has been added to the **Detailing** menu, which allows you to display the tasks of a scenario of an assembly mechanism.

![Scenario Table](image)

**Tolerancing**

Tolerancing commands have been changed so as to be compliant with the ISO 5459 standard. The **Detailing > Datum Feature** command dialog box has been enhanced with the following possibilities:

- To have a symbol with an empty end;
- To have a list of datum targets;
- To use multiple references;
- To hook the reference on a translated dimension line.

![Tolerancing](image)

The new **Datum Target** command is also available in the **Detailing** menu.

![Datum Target](image)
The **Detailing > Geometric Tolerances** command has been enhanced with:

- The addition of new modifiers, including global modifiers (ACS and ALS);
- The ability to hook the tolerance onto an offset dimension;
- The ability to add parentheses and brackets to datum systems;
- The ability to add multiple arrows;
- The ability to add a modifier on a basic dimension.

**Occurrence parameter**

When creating an item of text in a title block, the new **Occurrence Parameter** option allows you to retrieve a property directly onto the occurrence of a part. This makes it possible, for example, to retrieve the manufacturing index of a part into a title block cell.

The option is also available in unfolding documents.

**Hatchings**

When the color in the edit hatching dialog box is cleared, hatchings are now displayed with the color of the part.
Unfolding

Part inclusion

When an inclusion operation is carried out in an unfolding document, if an assembly document is selected as a document to include, TopSolid now shows all parts of the assembly which offer sheet metal shapes. In that case, they are therefore the occurrences of the parts which are unfolded. The advantage of this is that if a user modifies a part from the assembly document, the unfolding will be updated without user intervention. For example, in the case of a part family occurrence, if the drivers of the part are modified, the unfolding will follow.

Lightweight marking

As with lightweight drillings, the sketches produced by a lightweight marking now pass onto the unfolding.

Multiple unfoldings

In order to control the manner in which unfoldings are created, the following options have been added to multiple unfoldings (from a BOM):

- The All Occurrences option creates unfoldings which will point to all sheet metal parts which exist in the assembly.
- The Occurrences of the Instance Families option creates unfoldings which will point to the sheet metal parts coming from family inclusions. In the case of other part inclusions, they will point to the part definition document.

Unfolding process

In the same way as for multiple unfoldings, the Unfolding process now provides, in a Work document, access to an advanced configuration. As a result, you can now select the occurrence processing option which should be applied.
Interfaces

Multiple export

The **Naming Convention** drop-down list in the multiple export dialog box has been replaced with a button of the same name which makes it possible, for each document type, to create its own naming convention in the manner of the referencing.

![Multiple export dialog box](image)

AutoCAD

When importing a DWG or DXF file, the **Basify Texts** option makes it possible for texts to be converted into line segments.

You can also indicate the access path to fonts in SHX format in the **Translators > AutoCAD > Import** section of the **Tools > Options** command.

![AutoCAD configuraiton dialog box](image)

AutoDesk Revit

**TopSolid** now supports **Autodesk Revit** family documents in RFA format. The interface is included in the IFC import module.

You can also export a document in **Autodesk Revit** format.
**IFC**

*TopSolid* has added an *Export Drilling Operations* option to the *Translators > Ifc > Export* section of the *Tools > Options* command. The option allows you to not take drillings into account in a document export. The option is also available in the advanced options of the export dialog box.

In addition, the new *Translators > Ifc > Preset* section allows you to predefined the entity types for import.

---

**FBX import**

The FBX import dialog box now has a new tab which allows you to import textures, to associate them with imported parts and to create associated *texture* documents. A recognition system based on file names makes automatic assignment possible in the texture properties.
**DSTV export**

The DSTV export now supports mirror parts and printings.

In addition, the Translators > Dstv section of the Tools > Options command now supports Punching and Powder type markings.

**Viewer**

**Measurements**

The Measure command is now available when viewing an AutoCAD file (DXF, DWG).

**PDM Explorer (Optional Module)**

**Validation**

TopSolid now makes it possible to validate external documents (Word, Excel, PDF, etc.) from TopSolid’Pdm Explorer.
What's New in TopSolid'Cam 7.17
This section describes the new features added to the **Machining** application of **TopSolid 7** software in version **7.17**.

## Drilling

### Drilling: contouring and pocketing

In cases where a hole is machined by contouring or pocketing, it is now possible to modify the **stock to leave on floor** and **stock to leave on wall** values directly in the label of machining parameters.

![Machining parameters](image)

### Drilling: starting point for optimization

In a drilling operation with numerous points, whether they be standard, 4X axial or 4X radial, it is now possible to select a **starting point** which allows for optimization of hole machining paths, by clicking directly on the given drilling in the graphics area.

![Starting point optimization](image)

### Radial 4-axis drilling: optimization of geometries

New optimization methods are available for a radial 4-axis drilling operation, in addition to the **No Optimization** and **Shortest Path** methods which were already available in prior versions.

![Optimization methods](image)
**Customized drilling: customized coolant document**

It is now possible to associate a customized coolant document to a customized drilling document.
2D Milling

2D milling: cylinder analysis in Geometry option

The search for similar geometries can be performed in the Geometry option of end milling and side milling operations, and also of the grinding by contouring operation.

2D milling: lead-in and lead-out at hole center

So as to provide users with the option to begin machining in the center, TopSolid has provided a new option in the Plunge and Retract tabs for end milling, side milling and grinding by contouring machining operations. This plunge mode is only used when machining complete cylindrical shapes.
**2D milling: improvement to user interface for sharp edges**

The Angle Management tab has been divided into two sections:

- Sharp Edge Management (for angles within the tool path)
- Chamfering In/Out (for lead in/out angles)

---

**Machining features analysis: open pocket MF**

The pocket MF now differentiates between the open pocket and the closed pocket. This information is taken into account in the machining features analysis for the purpose of associating the corresponding method.

**BoostMilling: automatic plunge in pre-drilling**

It is now possible to perform an automatic plunge in the pre-drilling of a pocket. In addition, the Peripheral Safety Distance of Plunge option makes it possible to force the plunge into a hole whose diameter is not much larger than the diameter of the mill, without having to greatly reduce the general peripheral safety distance.
**BoostMilling: optimization to plunge point change**

The BoostMilling lead-in spiral starts at the plunge point, if possible, instead of starting the spiral at the center of the pocket.

![BoostMilling lead-in spiral](image)

**BoostMilling: modification of cutting conditions after helix + 1 turn**

In order to reduce the risks of tool breakage during the plunge, the modification of cutting conditions is now performed at the end of the helix + 1 turn by Z cut.

Example:

```
N130 S500
N140 G4 X2
N150 G3 X24.302 Y28.496 Z12.15 I2.666 J-1.375 F1500
N160 G3 X26.969 Y27.091 Z9.1 I1.125 J-2.997
N170 G3 X27.069 Y24.078 Z6.05 I-2.543 J-1.592
N180 G3 X24.5 Y22.5 Z3. I-2.642 J1.421
N190 G3 X24.5 Y28.5 I0 J3.
N200 G3 X24.5 Y22.5 I0 J-3.
N210 S3000
N220 G4 X2
N230 G3 X24.5 Y29.019 I0 J3.26 F1052
```
**Slot milling: leveling with compensation**

In the **Settings** options of a slot milling operation, the **Leveling** parameter has been replaced by a new **Contouring Integrated** tab, as for the side milling operation.

![Contouring integrated tab](image)

**2D milling: management of plunges outside of material**

It is now possible to add a descent other than direct for the plunge outside of material. Options are available for the end milling and contouring operations.

![End milling: Settings](image)
**End milling: modification of algorithm to respect stepovers**

Tools which have an end diameter different from the nominal diameter (cases of chamfer and radius) are now managed. That diameter will be taken into account in the calculation so as not to leave residual material.

![Diagram](image)

**2D milling: geometry part association**

Association of the part to be machined based on the face selected is now automatic.

**2D milling: label management**

The new **Limit Number of Information Labels** option in the **Machining > Dialog Configurations** section of the **Tools > Options** command allows you to define the **maximum number of information labels**.

![Options](image)
Side milling: customized lead-ins and lead-outs

A new Customized Lead-In/Lead-Out document which applies to side milling operations is available. It makes it possible to define, element by element, the approach and retract movements which can be used in the milling.

End milling: calculation optimization

Calculation times have been optimized for end milling operations which have numerous islands.
3D Milling

3D contouring: change to plunges and retractions

An information message now appears in case of an automatic change by TopSolid to an approach or retraction (case of a tangential approach changed to direct approach).

That information will also be available via a tooltip directly in the operations tree.

3D contouring: overlap

The overlap option which already exists in 2D is now available for 3D contouring.

Constant Z: improvement to user interface

The "Invert Side" concept has been removed to make way for "machining direction" which is more consistent with how the operation functions.

3D milling: pattern management

In order to reduce the number of machining operations as well as calculation time in TopSolid, it is now possible to duplicate tool paths by means of patterns, as is already the case in 2D.

Planar faces machining: approach from outside

Starting from version 7.17, a plunge outside material will be selected automatically for planar faces machining whenever possible.
**3D milling: plunge outside material**

For the plunge outside material, you can select a plunge strategy other than Direct for the following operations: 3D roughing, under cutting roughing, planar faces machining and roughing finishing.

![Plunge and retract settings](image1)

**3D milling: generalized retract management**

It is now possible to influence retract feed rates for the following operations: 3D roughing, under cutting roughing, planar faces machining and roughing finishing.

![Retract settings](image2)

A new Z tangent retract option is likewise available for planar faces machining.
**3D milling: use and control of profiles**

It is now possible to specify a cutting profile to define the tool shape. A checking function for this user profile has been added to ensure it can be used by the path calculation algorithms. If the profile check fails, a warning message is displayed and the path is not calculated.

![Provide Function](image)

**Roughing: collision management on the junction between the shank and the cutting part**

The safety height is now taken into account on the junction between the tool shank and the cutting part of the tool, thereby enabling it to get closer to the part.

**Constant Z: scallop height management for barrel cutters (adaptive step)**

The management of the Z step based on the scallop height is now improved for barrel cutters. It is now possible to adapt the Z step according to the section of the tool that is in contact with the part.
**Constant Z: optimizing the approach with spiral mode**

In version 7.16, when approaching an open path end in spiral machining mode, a slope plunge was systematically added without being requested by the user.

This behavior is no longer applied in version 7.17. **TopSolid** only applies the approach requested by the user.

![Diagram of spiral mode approach]

**Constant Z: path extension/reduction**

**TopSolid** no longer switches to sloping approaches if the requested approach is not possible due to collisions with the finish.

It is now possible to extend or shorten the path used to get to an area where the desired approach is feasible.

![Diagram of path extension/reduction]

If a collision-free approach is not possible despite of the path extension, **TopSolid** will switch to a direct approach instead of a slope approach.

A warning will then be shown in the events log.
**Superfinishing: avoid planar faces**

A new option called *Avoid planar faces* is available in the superfinishing operation settings. This enables planar faces to be avoided at the time of calculating the path.

![Avoid planar faces](image)

This option does not eliminate parts of the path that are exclusively in contact with the edge of a planar face. If this happens, it will be necessary to restrict the machining area.

**Roughing: management of high speed mills**

It is now possible to machine in roughing using a high speed mill. The supported profiles for a high speed mill are as follows:
**Residuals: bounding curve and residual remachining**

During a remachining operation limited by a curve, it is now possible to either avoid or perform high speed retraction movements for feed rate links.
5D Milling

Multi-axis pocketing: improved user interface

Automatic mode is now available for multi-axis pocketing finishing (side and bottom finishing), port machining and deburring operations.

Multi-blade: fillet selection in the Geometry option

You now have the option of selecting the blade/inter-blade fillet faces.

Multi-blade: fixture management in multi-axis pocketing (roughing)

You can now define the fixtures for multi-axis pocketing operations.
**Multi-blade: use of barrel tools**

Barrel tool families are now available for multi-axis pocketing finishing operations.

The new *Tool contact* section allows you to manage the contact point for this type of tool.

![Tool contact section](image)

**5 axis deburring: greater freedom of action**

The 3+2, 4X, and 4+1 inclinations are now available for 5-axis deburring operations. These make it easier to manage the tool’s freedom of action.

![5 axis deburring options](image)
Roughing 3+2: new operation

The new 3+2 Roughing command allows you to fully rough a part in different orientations.
Turning

Andrea head: management on MillTurn machine

In version 7.16, the collinear axes supported the use of an Andrea head. This meant that it only worked for orientations that were collinear to the X, Y or Z axis of the machine.

In version 7.17, the Andrea head supports machining in different orientations depending on the work coordinate system used.

Turning: plunge limitation

During a roughing or finishing operation, if the Plunge into pockets option is checked, TopSolid now allows you to make exceptions in order to indicate the pockets you do not wish to plunge into.

Threading (cycle): end point the same as on a machine

To obtain results in line with machine production, the end point of the threading operation is now included at the same level as the starting point of the operation when NC cycles are requested.

Threading: new cycles

Two new threading cycles are available: constant depth alternating flank threading and constant volume alternating flank threading.
**Parting-off: automatic mode**

It is no longer necessary to preselect a geometry for the parting-off operation. The *Automatic parting off* option automatically positions the path between the part holder and the finished part.

![Automatic parting off](image)

**Finishing turning: stock management**

The *Take into account the stock shape* option is now available for finishing operations in turning.

![Take into account the stock shape](image)

**Turning: screw threading**

A new *Screw threading* primitive is available for the threading operation. It enables the machining of both large threads and special threads. This makes it possible to machine threads with "standard" turning tools such as groove tools.

![Screw threading](image)
**Turning (roughing and finishing): stock size modification**

It is now possible to apply offsets to the stock profile, as can currently be done with milling with the clearance.

![Face Diameter clearance](image)

**Swiss-turning: part support with sub-spindle**

A new **Part support with driven element** is available in the virtual jog. If this jog element is selected, the sub-spindle will be controlled by the main spindle and must follow all the movements of this main spindle.

![Virtual Jog: Operation Settings](image)

**Security area retraction**

An **Altitudes** tab is now available in the turning operation settings. This allows you to define a position to be reached and to choose/prioritize the axes used to reach this position.

![Roughing: Settings](image)
Inter-operations

Multiprogram: force retraction at the tool change point

In order to avoid iso generation problems when using multiple programs (e.g. one program per operation), it is now possible to force retraction at the tool change point at the end of each program.

Link movement rules: machine changeover

When changing machines, it is now possible to automatically retrieve a document of link movement rules. If only one link movement rule document is linked to the new machine, it will be directly allocated to the machining document. If more than one link movement rule document is linked to the new machine, a dialog box will appear allowing you to select one.

Link movements rules: new criteria

New criteria are available in the link movement rules: PP word of the operation, Tool chuck distance and Tool property.

Link movements: using the settings

When saving a link movement, the settings it uses are all saved as well. If a particular setting is present in the final machining document, it will automatically be found and applied.
**Link movements: security sphere**

Movement on the security sphere is now managed by TopSolid.

**Link movements: local simulation**

A local Preview mode is available in the Link Movement Definition dialog box to determine whether or not simulation is required.
**Link movements: unwinding the axes supporting the tool**

For machines with a rotation axis on the head, it is now possible to force a rotation reset from the Work Coordinate System context.

If the **Reset tool holder axes if its rotations change in the interoperation** option is checked in the **Link Movements** section, a coordinate movement is added to reset the rotation axes that support the tool to 0°.
Tools and Cutting Conditions

**Tools: automatic selection for new operations**

The new Mount tool for new operations option in the Machining > Dialog configurations section of the Tools > Options command allows you to choose whether TopSolid automatically mounts a compatible tool when creating a new operation.

**Driven points: 3D tool management in the machining document**

The management of driven points for 3D tools is now saved and can be changed in the machining document options.
Driven points for 3D tools: verification of driven points based on the configuration

When generating the ISO code for 3D tools, TopSolid now checks whether the driven point used for each operation corresponds to what has been defined in the document options. A warning message will be displayed if the operation uses a different point.

![Warning message for driven points](image)

Driven points: default definition

It is now possible to edit and define the default driven points of a tool from the magazine, as well as to set the gauge numbers.

![Default driven points for first operation](image)

Cutting condition: ISO output type for feed rate

For specific conditions, it is now possible to choose the feed rate and/or spindle rate units in a cutting conditions document.

![Feedrate and spindle rate units](image)

These units can also be specified for the abacus.
Cutting condition: export to TopSolid’PartCosting

Cutting condition data can now be exported in CSV format so that it can be used outside the CAM environment (in TopSolid’PartCosting, for example).

Tools: driven point mapping

If you replace one tool with another from the tool magazine, a new dialog box appears after selecting the new tool, listing the used driven points.
**Tools: copy and paste with index number and height-diameter offset number**

When copying and pasting a tool, the offset numbers (index + height + diameter) are now duplicated. The same applies to the inclusion of one machining document in another machining document, if the tool does not exist in the destination machining document.

**Cutting condition: customized coolant document**

In a cutting conditions document, a new icon located to the right of the machine list now allows you to reference a customized coolant document.
Verification and Simulation

**Verification: default settings in options and company options**

It is possible to set verification default options in the general options as well as in the company options.

**Verification and simulation: linked machine elements**

A new *Do not check linked machine groups* option is available in the verification options. This allows you to skip detecting collisions on machine elements that are linked together.
**Cam Simul: various improvements**

**Views**
The Reviewer, Messages and History views (windows) are now available in Cam Simul.

**Collisions display**
The collisions display is now available in the Messages view. By selecting one of the collision lines, the Save Simulation option allows you to review the tool in position during that collision.

**Visibility of machine elements**
A new Display icon is available in the toolbar to the right of the graphics area. It is identical to the one shown in the TopSolid view. It allows you to select the visibility of the machine components.

**Cam Simul: integration of the “raytracing” window**

The new Show the Stock Window command, accessible from the command bar, allows you to display the stock window more accurately.

**Cam Simul: external ISO code simulation**

It is now possible to load and simulate an ISO file that was originally generated by TopSolid'Cam but subsequently modified in the workshop.

Access to loading an external ISO code is done directly from the Program window.

**Cam Simul: new option to boost calculation**

It is now possible to calculate the material removal and to detect collisions without having a graphical simulation. The quick simulation can be run from the simulation bar.
**Cam Simul: new pre-analysis command**

A pre-analysis command is now available in **Cam Simul**. This avoids running long simulation processes when errors are detected in the data analysis and allows you to estimate the simulation execution time.

**Optimize: new management**

Two new commands are available in **Cam Simul**:
- The first command allows you to record the cutting conditions during a simulation.
- The second command allows you to launch **Optimize** when the simulation is finished.

**Simulation: dynamic graphic cut**

You can now see the graphic cut move in simulation with the kinematics of the machine when it is based on a plane.
Methods

Broaching: availability in methods

You can now create a method with a broaching operation.

Method: machine element activation

The new **Machine Elements Activation** function enables a removable tool holder to be activated via a method.

Copy and paste operations: various improvements

When pasting a machining operation into another document (or when "pasting graphically" into the same document), it is now possible to change the image size vertically.

In addition to this, when copying and pasting between two machining documents, it is now possible to search for cylindrical faces similar to a reference face.

Method: asynchronous calculation

It is possible to activate asynchronous mode for some operations during the execution of a method.

Copy and paste operations: assignment of a tool to the same tool holder and pocket

When copying and pasting operations between two documents, **TopSolid** searches for a tool holder with the same name in the destination and source documents, then searches for an identical pocket.
**Method: link movements by formula**

You can now select a link movement document from the Functions > User variables menu of a method document. This allows you to retrieve this document via a VB or TopSolid formula.

**Method: drilling and turning**

Drilling and turning operations using two tools are now supported in one method.
Miscellaneous

Scenario: colors by operation

Colors can now be customized for each type of operation in the Machining > Scenario section of the Tools > Options command.

Scenario: default configuration

You can now configure a default scenario in the Machining > Scenario section of the Tools > Options command.

Scenario: synchronization point colors

A color is now used to identify the manual synchronizations entered in the link movements in order to more easily differentiate them in the scenario.
**CAD for CAM: coordinates system (XYZ) based on the reference plane**

The Name Axes According to Frame option is now available in the machining document options and in the positioning dialog box of the planar sketch.

In turning, it is therefore possible to work in the ZX plane while also having the corresponding coordinates when working in the ZX (or ZY) plane.

**CAD for CAM: improved sketch smoothing command**

A new Exact option is available in the tolerance smoothing command. When this option is checked, the approximation of the profile to B-spline is performed by converting the curves to gain an exact conversion with no loss of accuracy.

**MF creation: default activation**

When MFs are activated in the part document, they are now visible and usable in the machining document (Cam/Wire).

**Machined part setup document: various improvements**

The user interface has been improved with a restructuring of the diameter, length and margin settings for cylindrical stock.

Concerning the automatic dimensioning, annotations have been added on cylindrical stock (dimension of the drilling diameter).

**Positioning wizard: on the fly deactivation option**

You are now able to disable the positioning wizard in machining documents on the fly using the same command as that available in the assembly document.
Inclusion in last positioning: status stored in the document

The Inclusion in Last Positioning mode has been split into three modes available in the drop-down menu.

3D sketch creation on the tool path: points and/or profiles

You can now build a sketch that can be used in a machining context from a machining path.
**Analysis: easy distinction of the reachable geometries**

A new analysis tool has been made available to help identify the reachable faces and the type of machining to be done on the different faces of a part more easily. It allows you to configure the colors you want to see associated with the types of machining. These colors can be selected by checking the corresponding boxes.

**Default values: associating a user set with a TopSolid generic set**

The user parameter sets were previously referenced to the unmodifiable TopSolid parameter set. You can now change the reference parameter set in the default settings.
**Default values: various improvements**

**Administrator management**
When **TopSolid** works in client/server mode with "n" clients, administrators can force certain default values for everyone.

**Script management**
The `<scripts>` in VB or C# added in the default settings are now saved and preserved when **TopSolid** is restarted.

**Workshop document: scenario table**
A vertical and chronological table of scenario-based machining operations is now available in the workshop documents.

![Scenario Table](image)

**Scenario: icon visibility**
More than one icon can now be shown in the same scenario operation.

![Scenario Icon Visibility](image)

**Workshop document: part initial stock dimensions**
In the workshop documents, the new property `PartInitialStockDimensions` allows the annotations placed in the setup document to be automatically displayed.
**Part replacement wizard**

In the part replacement wizard, the new **Add Back Referenced Documents** button allows you to automatically find and add all documents relating to the setup document.
Grinding

Cylindrical grinding by profile facing

The use of a (complete) circular profile is now possible for cylindrical face grinding.

Cylindrical grinding by profile contouring

The use of a (complete) circular profile is now possible for cylindrical contour grinding.
Wire

Sort by regime number: roughing/finishing operation

It is now possible to sort operations by regime number.

M, G, direct block and PP word codes in lead-ins/lead-outs

The M, G, direct block and PP word codes accessible in the lead-in and lead-out movements for each machining operation are also available in wire.

Start/Finish add vertical synchros

The default activation or deactivation of the Start/Finish Add Vertical Synchros option can now be done directly in the wire document options or in the general wire options.
Displaying the undersize in the cutting conditions table

It is now possible to show or hide the **Downsizing** column in the cutting conditions table.

Adding a stop before the end of the falling part

When creating a wire geometry, it is possible to define a stop position before the end of the falling part. This positioning can be determined as a percentage of the total length of the falling part or by a distance, and this for each point in case of multiple falling parts.

In order to make the stop point effective, the new **Stop before falling part** option enables a stop (M0) to be added to the path.

Wire technology: new filters in methods

New filters are available for the **Technology Selection** action in wire methods documents.
**Regime change**

It is now possible to determine the distance of the wire docking to the part profile in the event of wire inclination. This allows the wire to enter the material along its entire length.

![Image of TopSolid 2023 interface](image)

**Downsizing in geometry**

When creating the cutting operation for downsizing, three types of downsizing are available:

- **Operation**: This is the default type. This functions the same way as in version 7.16. It is the downsizing of the operation that is taken into account.
- **Geometry**: Only the geometry downsizing is applied. The question in the operation is grayed out.
- **Geometry + operation**: The two downsizings are added together.

![Image of TopSolid 2023 interface](image)
Reading UNIQUA wire technology: GF

All the new GF group Charmilles and Agie machines now use the UNIQUA system. It is now possible to read technology files via UNIQUA.
Cam Operator

Show/Hide in the Operations tree

It is now possible to show or hide the paths on the screen from the Operations tree. To do this, simply activate or deactivate the eye icon in the Operations tree.

Graphic selection echo in the Operations tree

From the graphics area, clicking on the path shown on the screen places the cursor directly on the corresponding path in the Operations tree.

3D rotation of the part

TopSolid’Cam Operator can now perform a 3D rotation for tablet mode.

Document modification rights management

The PDM administrator can now decide which user has the permissions to edit an existing Cam document.
**Viewing the tool**

Tools will now be visible in the graphics area while they are being edited.

**ISO generation: tool par tool**

It is now possible to generate the blocks for a single tool. To do this, simply display the NC operations tree, bring up the contextual menu (right click) on the tool in the NC operations tree, then generate the ISO code.
What's New in TopSolid'Tooling 7.17
This document describes the new features of the Split, Mold, Strip and Progress applications in TopSolid 7 version 7.17.

**TopSolid'Split**

**Parting shapes**

**Part colors**

You can now transfer the colors of the colored faces of a part onto core cavity blocks.

To take advantage of this new feature, the following settings should be used:

- Work from a Split template document.
- Set the **color** options as shown below.
- Uncheck the **Remove face colors** option in the **Shape to Split** command.
Colors

You can now change the colors applied to the parting shapes. You simply have to select the required shape from the list of created shapes and adjust the color of the molding area, parting surface and/or insert.
TopSolid’Mold

Document

The new **Mold Set** mode allows you to arrange the synchronized parts of the mold in the Project tree. They can therefore be organized by category, by mold set or both simultaneously.

Here is an example with a mold base installation:

**Categories sets subfolders**

**Mold sets subfolders**

**Categories and Mold sets**

**Code storage for mold bases**

When a mold base is installed and the type of mold base is changed, the code chosen will be stored.

**Drilling collisions**

Collision detection between drillings and part edges has been improved to avoid the false flagging of collisions.

As shown in the example below, TopSolid previously detected a collision between the margin countersinking and the pocket faces.

Now, thanks to changes made to the collision margin measurement, this collision will no longer be flagged.
**Cooling**

**Include component**

As it is rather difficult to include components manually in a cooling sketch, the **Include Component** command has been redesigned to simplify these inclusions.

**TopSolid** now shows the various relevant positions using yellow ball symbols. After selecting a reference position (yellow ball), users can offset the component and/or reverse its positioning. After confirming, a linear dimension is created from the reference position selected by the user.

![Different reference positions are proposed.](image1)

![The dimension is created using the selected position.](image2)

**Input and output editing**

The cooling circuit input and output management has been redesigned. Input and output selection is done on the exit face of the cooling circuit positive. It is now possible to define an input and an output for the same drilling.

![Input and output editing](image3)

In addition, the inputs and outputs can also be defined on cooling shapes without automatically including a connection.
**Cooling process: creation of drilling MFs**

If the **Create MFs** option is activated, the cooling process creates drilling MFs for each drilling in the cooling circuit.

**Analyze cooling**

**Analysis without creation of cooling processes**

The **Analyze cooling** command allows users to graphically visualize the influence of the cooling circuits on each point of the parts to be molded.

You can now run this analysis **without** having performed the part cooling processes, because the analysis is based on the cooling positives.
Cooling shapes

The Analyze Cooling command can now manage "classic" cooling processes as well as those created using cooling shapes.

![Several cooling processes with cooling shapes.](image1)

The cooling processes created from cooling shapes are included in the cooling analysis.

Blade pins

In the Pin command, the new Blade orientation section, only displayed for blade pins, enables the user to define the orientation of the pin blade in relation to a reference direction. This orientation is separate from the keying orientation.

It is automatically calculated based on the pin's inclusion mode:
- **Positioning on point**: The direction is the same as the keying direction.
- **Positioning on an edge**: The direction is determined by the edge.
- **Positioning on profile point**: The direction created is a direction on profile with this point acting as the origin.
- **Positioning on symbol**: The X direction of the symbol "base" frame.

Identical pins by repetition

In the Pin command, the new Identical pins by repetition option allows users to position a pin and repeat it using a sketch pattern. The pattern is automatically constructed using the sketch.

This option is available only when the selected Sketch mode is Points. The Circles mode must be unchecked.

All the pins are identical. No limitation control is performed.
**Angle pin**

**Delay management**

In the *Process on slide* section of the *Angle pin* command, the new *Oblong* mode enables users to create an oblong type machining on the slide. This makes it possible to manage any delay in opening the mold using the pin stroke.

![Process on slide](image)

**Positioning on frame**

In the *Positioning* section of the *Angle pin* command, the new *Frame* mode enables users to easily include and position a pin in a pin housing component by placing it under the pin head.

![Positioning](image)
**Drillings marking**

The new **Drillings Marking** command enables users to engrave different drillings on the mold plates, whether they are produced by a drilling operation or by using a process. The text to be marked can be specified for each identified drilling.

![Marking of drillings and inputs/outputs of cooling circuits.](image)

**Springs**

The new **Springs** command enables users to include and size multiple springs simultaneously in the tooling. At the time of inclusion, a label shows the features of the springs selected in order to size them appropriately:

- The **total compressed length** taking into account the indentations;
- the **free length of the spring**;
- the **percentage used**;
- the **resulting force** (the calculated force takes into account the number of springs included).
Hide components

In a draft, the new Hide Components command enables users to hide a component and its process on a projection. The missing hatchings are reconstructed.

Many of the components are installed symmetrically.

The cut can be lightened by hiding these components and their process.
TopSolid'Electrode

Electrodes from a surface part

When importing a part from outside (IGES for example), it can be difficult to sew all the surfaces of a complex part. It is now possible to create an Electrodes document from a surface part. The shape to erode will therefore similarly be of surface type. The definition of the electrodes remains identical: creation of the shells, the eroding shapes and the electrodes. Only the face mode is available for shell creation.

Shell creation preview

It is now possible to enable or disable a shell creation preview. In surface selection mode, the shell's boundary edges are displayed and allow a better view of the shell to be produced.

Eroding shape

Fillets with lateral extensions

It is now possible to add fillets to the edges of automatically detected and laterally extended grooves. The fillet is applied uniformly to the entire eroding shape.

Merge faces

In the advanced options of the Eroding shape command, the new Merge faces option enables users to merge all the faces produced when the shell is extended. Only the faces that are not produced by the shell will be impacted. If the Eroding area color option is applied, the following type of result is obtained:
**Orientation markers and electrode markers**

Users can now define electrode frames (machining frame, machining positioning frame or EDM frame) using a frame created in an orientation frame. To do this, this frame must be provided with the new **Orientation marker frame**.

An example of a component producing a frame has been added to the TopSolid Electrode library: **Calibration with chamfer**.

Creating electrode markings used to be done electrode by electrode, which could be long and tedious task if a lot of electrodes were involved. Users can now create the same marking by automatically selecting a batch of electrodes.

**Electrode/mandrel assemblies**

The new **Electrode/Mandrel Assemblies** command allows users to create an assembly document for each selected electrode. This document includes the electrode and its mandrel associated with it in the electrodes document.

This assembly can then be machined via the **Machining** contextual command. The electrode will automatically be considered as the **finish** and the mandrel as the **environment** in the **machining setup** document.
Initial positions

The new Not managed option, checked by default, enables users to avoid creating electrode parts in initial positions in the document. Any users seeking to systematically create initial positions are recommended to deactivate this option in an Electrodes template document.

TopSolid'Progress (Progressive Die)

Springs

The new Springs command enables users to include and size multiple springs simultaneously in the tooling. At the time of inclusion, a label shows the features of the springs selected in order to size them appropriately:

- The total compressed length taking into account the indentations;
- the free length of the spring;
- the percentage used;
- the resulting force (the calculated force takes into account the number of springs included).
What's New in TopSolid'Cut 7.17
This section describes the new features added to version **7.17** of **TopSolid’Cut**.

**Skeleton Cutting**

*Skeleton cutting based on the new 2D operation*

The skeleton cutting command has been modified and enhanced in version 7.17. From the **Management** menu, the new **Skeleton Cutting Management** command allows you to define the default skeleton cutting settings.

Several **cutting types** are available from the command window.

It is also possible to choose a **starting point** for cutting.
It may be necessary to define a **number of cuts**, depending on the type of cut selected.

In the example below, for a **Horizontal then Vertical** cutting mode, 5 horizontal cuts and 5 vertical cuts have been entered.

![Skeleton cutting management](image)

Here is the resulting skeleton cut:

![Skeleton cut result](image)

To obtain the above result, proceed as follows:

- From the **Cutting** menu, select the **Automatic Machinings** command to perform the cuts on the *Horse* part.
- Confirm the operation.
- From the **Cutting** menu, select the **Skeleton Cutting** command to perform the cuts on the shape.

The number of cuts will match the setting previously made in the **Skeleton Cutting Management** command.
This command can be edited via the contextual menu (right click).
• Right-click on one of the skeleton cuts and select the **Delete** command to delete the skeleton cuts. **Note:** Users can also select the **Delete** command from the **Cutting** menu.
• Click on the **Skeleton Cuttings** icon in the **Delete** command.

• Confirm the deletion operation.

You can perform the skeleton cuts in the nested sheet metal document.
Waste Cutting

Waste cutting based on the new 2D operation

The waste cutting command has been modified and enhanced in version 7.17. From the Management menu, the new Waste Cuttings Management command allows you to define the default waste cutting settings.

You can define the **minimum size** and **waste type** from the command window, as well as the **number of micro tabs** and their **width**.
- Select the **Waste Cutting** command from the **Cutting** menu.

In the example below, an L type waste cut was made using a micro tab.
Waste cutting can be edited via the contextual menu (right click).

The size of the waste can be set in **Free** mode.
The orange handles allow you to manually and dynamically adjust the size of the waste cut.

Incremental mode allows you to adjust the size of the waste cut with a given step.

Example of a waste cut size adjustment:

After confirming the operation, the waste cut is generated. This results in the creation of a part document.
This document can be used as a support for a new nesting.

Waste cutting can be done in sketch mode to obtain a cut of any shape.

- Switch to CAD mode to access the sketch commands.
- Draw the desired sketch.
• Switch back to Sheet metal Cam mode.
• Right-click on the sketch and select the **Waste Cutting** command.

• Confirm the operation.
Delivery of Standard Leads by Default

*Leads catalog*

You can now automatically compile a leads catalog.

- Select the **Standard leads** command from the **Management** menu.
- Click on the **Import** icon.
  A dialog box appears, allowing you to import the file containing the standard leads.
- Click on the **Import File** button.
• From Windows Explorer, select the *Standard leads.txt* file and click on the **Open** button.

The standard leads catalog is compiled automatically.

The **Export** icon enables users to export the leads catalog.
Common Cutting

A lot of changes have been made to the automatic and manual common cutting commands.

For automatic common cutting, the new **Common Cuttings Management** command in the **Management** menu allows you to set the default settings for the **Common Cutting** command.

The command window allows you to select **internal**, **mixed** and/or **external** cuts, to set the **offset** corresponding to the common cutting distance stated in the nesting and to choose the **order** of the cuts, either internal then common, or mixed.

- To perform a common cut, select the **Automatic Machinings** command from the **Cutting** menu.
The **Cutting**, **Links** and **Common cutting** icons are activated in the command window.

With this selection, all internal cuts and common cuts will be performed with links.
The settings can be accessed by clicking on the **Common cut** icon.

- To perform a manual common cutting operation, select the **Common Cut** command from the **Cutting** menu.
- Manually click on each segment where you want to perform a common cut.

The geometries are centralized in the command window.

- Confirm the operation.
The automatic or manual common cut operations can be edited by right-clicking on the cut.
Automatic Link Bypass

To avoid generating hazardous links between cuts, the new **Dangerous Links Solving** option enables links to be set to paths that bypass previously machined geometries.

In automatic machining mode, in the **Checkings** command on the **Management** menu, if the link checking is set to the **Head up and Down** mode, the link bypass will be performed automatically.

In manual machining mode, proceed as follows to bypass hazardous links when the geometries to be cut are selected:

- Click on the **Links** icon.
- In the command window, check the **Dangerous Links Solving** option.
- Select the type of bypass (Strict or At the shortest).
The result is as follows:

The command can be accessed via the contextual menu (right click).
Scrap Cutting

A new scrap cutting option allows users to make cuts inside part slugs. Two modes are available: Automatic or Manual.

- For automatic mode, select the Automatic Machinings command from the Cutting menu.
- The Cutting, Links and Scrap cutting icons are activated in the command window.

Click on the Scrap cutting icon to access the settings.

In the example below, the following settings have been entered:
- the minimum size of the elements that will support a scrap cut (5 mm);
- the maximum size of the elements that will support a scrap cut (800 mm);
- the type of cut (horizontal then vertical);
- the number of horizontal cuts (4);
- the number of vertical cuts (4);
- the indented lead.
The result is as follows:
• For manual mode, select the **Cutting** command from the **Cutting** menu.
• Click on the **Scrap cutting** icon.
• Enter the relevant settings.
• Click on the **Geometry** icon.
• Select the geometry to which the scrap cut will be applied.

This command can be edited via the contextual menu (right click).
Show/Hide the Start and End Points

A new view command, located at the bottom right of the graphics area, allows you to show or hide the start and end points of the cutting paths.

By default, the start point of the path is represented by a green square.

By default, the end point of the path is represented by a white square.
Additional Positionings for a Unit Part

In a sheet metal cam document, the Unit Part command in the Nesting menu provides additional positioning options:

- Center
- Top Center
- Bottom Center

Clamp Management

You can now program cutting machines fitted with clamps. The clamp settings can be entered in the Include Clamp command in the Equipment menu.

You can position the clamps dynamically by clicking directly on the clamp.
**Shifting Area Management for Clamp Machines**

Machines fitted with clamps can now be used, requiring the management of shifting or repositioning areas.

A shifting area is represented by a red dotted line.

The *Shifting Areas* command in the *Equipment* menu allows you to set up the shifting areas.
The parameters of the shifting areas can be set in the **Shifting Areas Definition** section.

Shifting areas can be dynamically adjusted by clicking on the arrow for the relevant zone.
The **Part(s) in shifting areas** command allows users to insert parts in a given zone.

---

**Evacuation of Parts through a Chute Door**

Version 7.17 includes a new feature enabling the evacuation of parts via the chute door of a machine.

You simply have to select the cutting command (manual), click on the **Chute door** tab to enter the settings, then click on the **Geometry** tab and select the geometry of the part to be evacuated via the chute door.
The chute door push length is dynamically adjusted using the mouse.

Retrieval of a Machined Format as a Support

You can now retrieve a machined format to be used as a support.

A machined format is deemed to be a standard support in the nesting for the arrangement of a new position. The parts will be positioned taking into account the holes in the sheet.
Work Manager

Archiving order

The new Archive Works command allows you to archive completed jobs to make the work manager operate smoothly. Works must be completed in order to be archived.

![Archive Works screenshot]

The Archived Work(s) command allows you to view archived works.

Quantity management

Part quantities can be managed in version 7.17.

If the parts quantities cannot be produced (insufficient number of supports, for example), you will be notified through a message and color coding.

In the Made Quantity column, the red lines mean that no parts were produced, and the orange line indicates that parts were partially produced and the full quantity was not able to be produced.

![Quantity management screenshot]
The **Copy task** command allows you to copy tasks to restart their production.

Here is an example of a full parts production (red box):
**Work Document**

**Exporting results to Excel format**

In the Work document, the new **Nesting results Excel Export** process allows you to export the nesting results into Excel format.

The resulting Excel file will filter and present the results in two separate tabs:
- Nestings
- Parts
What's New in TopSolid'PartCosting 7.17
This section describes the enhancements made to the TopSolid'PartCosting application in version 7.17 of TopSolid 7.

**Turning on a 3D Drawing**

Version 7.17 provides the option of using 3D drawings to facilitate calculations on turning parts. In a profile, a new tool allows you to choose a cutting drawing perpendicular to the axis of rotation and automatically generates a plot that can be used to calculate turning operations.

**Profile Without Drawing**

A phase profile can now be created without a part drawing. This generates a preset profile (origin and scale) ready for freehand drawing or for generating operations.
**Hourly Rates Management**

Several changes have been made to the hourly rates. Firstly, the hourly rates for the cycle time have been separated into a machine hourly rate and an operator hourly rate: machine times become the machine hourly rate and human times become the sum of the machine hourly rate and the operator hourly rate. Secondly, a variable amount of the hourly rate can be allocated to material groups, making it easier to take into account a different consumables cost depending on the materials in question.

**TopSolid’Cam Cutting Conditions**

*TopSolid’Cam* tool and cutting conditions libraries can be exported to an interim file and used by *TopSolid’PartCosting* to calculate times. You can opt to use either the *PartCosting* cutting conditions database or the data from the CAM environment to calculate machining times.
**Mill/Turn Spindle Speed Limit**

For mill/turn type machines, the spindle 2 speed limit is used for hole and milling operations.

**Sweeping Operation**

The cut depth has been added for sweeping operations in milling. The **Height** parameter is divided by the cut depth to obtain the number of passes.
What's New in TopSolid'Inspection 7.17
This section describes the new features included in **TopSolid’Inspection Creator**, **Controller** and **Analyst** applications in version **7.17** of **TopSolid 7**.

**TopSolid’Inspection Creator**

*Animated graphics over the balloon*

To help with navigating the part drawing, the balloon is positioned in the center of the screen (where possible) and an animated graphic can be used to show the user where the balloon is on the screen.

*Automatic ballooning*

Instead of performing ballooning one step at a time, automatic ballooning allows the user to select a general view. Any recognizable information is extracted in a window allowing you to refine and add to the checkpoint features. This saves a significant amount of time.
**Balloon numbering**

The addition of a secondary balloon number allows you to group balloons either alphabetically or numerically. Balloon numbers can be changed manually or automatically when copying a line.

**Surface state management**

An acronym can be flagged as a surface condition. This simplifies the process of tolerances management. This results in a specific behavior: the tolerances cannot be changed and take the value 0 and the roughness value. The unit attached to the acronym is used for the conversion of tolerances mm/micrometer and inch/microinch.
Link with TopSolid'Design

Ballooning functions are present in TopSolid'Design through the construction of a dimension table in a drafting document. A TopSolid'Inspection project can be created from this drafting document, thereby directly retrieving the checkpoints.

Improved OCR performance

When the Image option is checked in the project, the OCR comes into action to recognize the values. At this point, it will put forward a number of results from different image processing sequences before providing its interpretation. The results are classified according to a confidence score and shown in a drop-down list in the ballooning window.
**General tolerances**

Several additional general tolerance standards have been added to the standard data. The system now offers the option of using a tolerance table that depends on the number of decimal places of the retrieved value.

**Frame modification**

Once drawn, the frame can then be modified (re-drawn) from the label management or from the checkpoint details.
**Support for Windows scaling**

A Windows scaling factor greater than 100% enables OCR to operate. The screenshot must be positioned correctly.
**TopSolid'Inspection Controller**

**Displaying the drawing in Controller**

The interface for entering measurements can display the part drawing. An animated graphic allows the balloon relating to the control to be located easily. A mini entry window can be accessed directly on the drawing in order to enter the main information within the balloon.